While our upstream provider continues to have issues, we have resolved the performance issues on our end and publication websites and admin access is restored.
Posted Jun 10, 2025 - 15:08 UTC
Update
Publication websites may be slow or inaccessible due to ongoing issues with our platform provider. Heroku is still investigating and remediating issues with their services: https://status.heroku.com/incidents/2822. We continue to monitor this situation closely.
Posted Jun 10, 2025 - 14:23 UTC
Identified
Publication websites may be slow or inaccessible, and App Admin performance is degraded while our platform provider resolves ongoing issues. We're monitoring the situation closely.
Posted Jun 10, 2025 - 13:35 UTC
Investigating
We've been notified of an issue with our upstream platform provider and are currently assessing the impact on beehiiv publication websites.
Posted Jun 10, 2025 - 13:18 UTC
This incident affected: Publication websites, App Admin, and Public API.