Subscriber statistics delayed

Incident Report for beehiiv

Resolved

This incident has been resolved.
Posted Jan 18, 2026 - 21:07 UTC

Identified

An issue with our data warehouse means that currently some statistics reported in the beehiiv admin are delayed by multiple hours. We are actively working on a fix. No subscriber experience is effected and no data has been lost
Posted Jan 18, 2026 - 14:03 UTC
This incident affected: App Admin and Public API.