The beehiiv platform is currently unavailable

Incident Report for beehiiv

Resolved

Our team was able to get everything working again and all emails should be sending out as expected. Due to an issue processing segments within our system, we had degraded performance across the platform. Now that things are back to normal we will continue to spend additional time working on making things more stable and reliable in the future.
Posted Apr 09, 2026 - 13:38 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2026 - 13:24 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 09, 2026 - 13:16 UTC

Investigating

Due to an incident, the beehiiv platform is currently unavailable. Our engineering team has been notified and is working to restore service as soon as possible.
Posted Apr 09, 2026 - 12:55 UTC
This incident affected: Publication websites, App Admin, Public API, Sending emails, Email Metrics, and Embed forms.