Delayed dashboard metrics

Incident Report for beehiiv

Resolved

All data has caught up
Posted Feb 20, 2026 - 20:30 UTC

Monitoring

Data is catching up quickly now and we are continuing to monitor progress.
Posted Feb 20, 2026 - 20:16 UTC

Identified

Subscriber metrics on the main admin dashboard are currently delayed. The team has identified the cause and is working to get the data caught up. Publication websites, email sending, and subscriber signups are not affected.
Posted Feb 20, 2026 - 17:14 UTC
This incident affected: App Admin.