Intermittent errors and performance issues platform wide

Incident Report for beehiiv

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 10:04 UTC

Monitoring

Publication websites may be slow or inaccessible due to ongoing issues with our platform provider. While we have mostly recovered, Heroku is still investigating and remediating issues with their services: https://status.heroku.com/incidents/2822. We continue to monitor this situation closely.
Posted Jun 10, 2025 - 18:43 UTC
This incident affected: Publication websites, App Admin, Public API, and Embed forms.