Email Analytics and metrics are currently delayed
Incident Report for beehiiv
Resolved
All metrics are caught up and the delays are resolved
Posted Nov 25, 2024 - 19:36 UTC
Identified
Our email metrics pipeline is currently experiencing a backlog with recent interactions not reflecting in the statistics and metrics displayed for posts. Sending emails is still working and unaffected and we are working to restore real time metrics.
Posted Nov 25, 2024 - 18:53 UTC
This incident affected: Public API and Email Metrics.