Degraded performance on the beehiiv platform, delaying automation emails, segments, and welcome sends

Incident Report for beehiiv

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 16:21 UTC

Monitoring

We've implemented a fix that should improve automation emails and segments processing. We are currently monitoring the situation as things improve.
Posted Jan 22, 2026 - 16:02 UTC

Identified

We are working on restoring functionality, post sends are no longer delayed, but we continue to see delays in automation emails and segments
Posted Jan 22, 2026 - 15:21 UTC

Update

We are continuing to investigate this issue.
Posted Jan 22, 2026 - 14:07 UTC

Investigating

Due to excessive load on our primary database we are seeing delays in automations and segments and increased response times throughout the app. Our engineering team is investigating, as is our database vendor. We'll post updates as we have them.
Posted Jan 22, 2026 - 14:06 UTC
This incident affected: Publication websites, App Admin, Public API, and Sending emails.