Intermittent timeouts and performance degradation platform wide
Incident Report for beehiiv
Resolved
This incident has been resolved.
Posted Aug 07, 2024 - 20:54 UTC
Monitoring
We have implemented a fix and website performance has fully recovered. It will take a few minutes for delayed signups, split tests, and email sends to process but no data has been lost
Posted Aug 07, 2024 - 18:35 UTC
Investigating
Due to an influx of malicious traffic, we are seeing highly elevated timeouts across publication websites and the admin section, in addition to delays adding new subscribers and completing A/B tests. The engineering team is at work restoring service as quickly as possible.
Posted Aug 07, 2024 - 17:48 UTC
This incident affected: Publication websites, App Admin, Public API, and Sending emails.