Delays in email sending

Incident Report for beehiiv

Resolved

This incident is resolved. Our systems have caught up on the backlog of emails and operation is back to normal
Posted Sep 25, 2025 - 16:48 UTC

Monitoring

A fix has been implemented and we are monitoring our systems as they catch up on the backlog of emails.
Posted Sep 25, 2025 - 16:42 UTC

Identified

This issue has been identified and a fix is being implemented
Posted Sep 25, 2025 - 16:37 UTC

Investigating

We are experiencing delays in Post emails being sent. The team is currently investigating.
Posted Sep 25, 2025 - 16:17 UTC
This incident affected: Sending emails.